Story   Photographer   Editor   Student/Intern   Assistant   Job/Item

SportsShooter.com: The Online Resource for Sports Photography

Contents:
 Front Page
 Member Index
 Latest Headlines
 Special Features
 'Fun Pix'
 Message Board
 Educate Yourself
 Equipment Profiles
 Bookshelf
 my.SportsShooter
 Classified Ads
 Workshop
Contests:
 Monthly Clip Contest
 Annual Contest
 Rules/Info
Newsletter:
 Current Issue
 Back Issues
Members:
 Members Area
 "The Guide"
 Join
About Us:
 About SportsShooter
 Contact Us
 Terms & Conditions


Sign in:
Members log in here with your user name and password to access the your admin page and other special features.

Name:



Password:







||
SportsShooter.com: Member Message Board

Nikon D70 CHA problems
Dee Ritz, Photographer
Littlerock | CA | USA | Posted: 10:37 PM on 09.25.05
->> I've read about the blinking light of death but has anyone had this problem:
My Nikon D70, which I bought new in March of '04, has for several months had an intermittent problem with sudden 'CHA' error messages on the top LCD. Sometimes it'll show 'FOR' and if I attempt to format in camera, it won't. I can pull the card and the battery and sometimes, eventually, it'll work. But it seems to happen most frequently lately when I swap lenses. As I said it's intermittent but seems to be happening more often.

Perhaps I should send this thing in with the BGLOD complaint? I have a feeling they're related. Either way, I haven't a dime for repairs or another camera and I'm disgusted that I've only gotten a year and a half of life out of this thing. FYI, it's been treated with great care, never dropped, etc.

I appreciate any ideas or help.

Dee
 This post is:  Informative (0) | Funny (0) | Huh? (0) | Off Topic (0) | Inappropriate (0) |   Definitions

Mike Last, Student/Intern, Photographer
London | Ontario | Canada | Posted: 11:28 PM on 09.25.05
->> Hey Dee,

I have had that same probkem with my D70 for a few months now as well. I just take out the CF card and push it back into it's slot with some extra force. Same as you, it seems to happen more often when switching lenses. My camera was dropped once and had the top LCD replaced, but I don't think that would be the cause of random CHA errors. Just wanted to let you know that you arent the only one. Maybe someone has a fix?
 This post is:  Informative (0) | Funny (0) | Huh? (0) | Off Topic (0) | Inappropriate (0) |   Definitions

Adam Gerik, Student/Intern, Photographer
Peoria | IL | USA | Posted: 6:46 AM on 09.26.05
->> Same exact problem with my D70; also out of warranty, I'm afraid. It went in over Christmas break last year to have the pop-up flash fixed.... it simply stopped working. Fortunately, the 'CHA' problem usually works itself out if I pop the card out and then back in again.
 This post is:  Informative (0) | Funny (0) | Huh? (0) | Off Topic (0) | Inappropriate (0) |   Definitions

Adam Gerik, Student/Intern, Photographer
Peoria | IL | USA | Posted: 6:47 AM on 09.26.05
->> Now that I think about it, could it be a problem with failing compact flash cards? I'm not sure what the life expectancy on those are... and I would hope that my Sandisk Extreme's wouldn't already be failing.
 This post is:  Informative (0) | Funny (0) | Huh? (0) | Off Topic (0) | Inappropriate (0) |   Definitions

Samuel Lewis, Photographer
Miami | FL | USA | Posted: 7:38 AM on 09.26.05
->> Does the problem happen uniformly with other CF cards? If so, then it probably is the camera.

I just went through this with a recently purchased sandisk ultra 1gb card. Every other card, including three other sandisk ultra 1gb card works just fine. The most recent came up with CHA errors on a regular basis. Sandisk exchanged the card under warranty, and I have not seen the problem since.
 This post is:  Informative (0) | Funny (0) | Huh? (0) | Off Topic (0) | Inappropriate (0) |   Definitions

Mike Last, Student/Intern, Photographer
London | Ontario | Canada | Posted: 11:07 AM on 09.26.05
->> My card is a Lexar 1GB 40x card. I don't have any other cards around to test it on but I will look into that and see if it is the problem..
 This post is:  Informative (0) | Funny (0) | Huh? (0) | Off Topic (0) | Inappropriate (0) |   Definitions

Add your comments...
If you'd like to add your comments to this thread, use this form. You need to be an active (paying) member of SportsShooter.com in order to post messages to the system.

NOTE: If you would like to report a problem you've found within the SportsShooter.com website, please let us know via the 'Contact Us' form, which alerts us immediately. It is not guaranteed that a member of the staff will see your message board post.
Thread Title: Nikon D70 CHA problems
Thread Started By: Dee Ritz
Message:
Member Login:
Password:




Return to -->
Message Board Main Index
Copyright 2022, SportsShooter.com